Desktop Modeler Overview

Last update: Download PDF Edit

1 Introduction

The Mendix Desktop Modeler is the tool for creating, viewing, and editing your Mendix applications. A Mendix app is called a project in the Modeler. A project consists of many documents that are grouped in modules and folders. There are some project-level settings, but the core of the functionality is inside the modules. Examples of documents are project settings, domain models, pages, and microflows. One Modeler instance can have only one project open at a time, but you can open two Modeler instances when necessary.

This documentation describes the graphical user interface of the Modeler. The rest of the documentation follows the structure of the project explorer.

2 Dockable Window Panes

The Modeler supports a number of dockable window panes. You can close some panes to just show the ones you need at the moment, but you can always reopen them via the View menu.

The table below describes all the available dockable window panes.

Pane Description
Breakpoints (via Debug Windows) Shows all breakpoints in the project. You can enable/disable breakpoints from here.
Changes For Team Server projects, this pane shows the local changes to the project since the last commit. You can commit changes, update to the latest revision and view the history from here.
Connector Shows what elements can be connected to the currently selected element. For example, when a button is a selected, the connector will show microflows that you can drag and drop onto the button to connect them.
Console Shows the output of the Mendix Runtime while running an application.
Debugger (via Debug Windows) This can be used to debug your application.
Documentation Shows the documentation for the currently selected element (if applicable).
Error List Shows the errors and warning currently in your project.
Find Results Shows the results of the latest find action. You can search for text, for usages of an element (for example, attribute) and for unused items. There are two Find Results panes. If you lock the results of the first pane, the second one will be used for subsequent find operations until you unlock it.
Get Started Shows useful resources for getting started with the Mendix Modeler.
Project Explorer Shows the complete structure of your project including all documents inside the modules. By default the active document is always selected in the project explorer so you can quickly see where the document you are editing is in the tree. You can change this behavior in the Edit > Preferences window pane.
Properties Shows properties of the currently selected element. This is where a lot of editing in the Modeler takes place.
Stories For Team Server enabled projects, this pane shows the stories of the current sprint.
Toolbox Shows the tools that can be used in the current editor. For example, in a page you can insert all kinds of widgets (for example, text box and data view) by dragging them from the Toolbox to your form.
Variables (via Debug Windows) You can view the current values of variables here when debugging your application.

3 Document Tabs

Documents that you are viewing and/or editing at the moment are shown in tabs. You can have a number of tabs open, just like in a modern web browser. They can be closed, reordered, and shown side by side. Each document has its own save state and history/future. Undo and redo actions are unlimited.

Using items in the menu bar of the Modeler, you can create new projects, deploy and run them, search for text, and more.

4.1 File Menu

Menu Item Description Shortcut Key
New Document Creates a new document within the project that is currently open. You can choose the name, location and type of the document. Ctrl + N
New Project Creates a new single-developer project. A single-developer project is simply a file (with the extension .mpr , which stands for “Mendix project”) that is stored in the local file system. Ctrl + Shift + N
Open Project Opens an existing single-developer project (.mpr) or a project package (.mpk). See New Project above for information on single-developer projects. Ctrl + Shift + O
Recent Projects Shows a list of recently opened projects for quick opening.
Save Saves the changes in the currently active document tab. Ctrl + S
Save All Saves the changes in all documents that are open. Ctrl + Shift + S
Close Closes the current document. You will be asked to save or discard changes when needed. Ctrl + W
Close All Closes all document tabs. You will be asked to save or discard changes when needed. Ctrl + Shift + W
Close Project Closes the currently open project and return to the start page.
Export as Image Exports the current document as an image in the .png format. The following document types can be exported as images: forms, microflows, domain models, document templates, and XML mappings.
Export Project Package Exports the current app to a project package (.mpk) file. This is useful for example when you want to give someone the entire app, or when you need to provide a test app when submitting a ticket.
Import Project Package Imports a project package that was created with the Export Project Package menu item.
Exit Closes the Modeler

4.2 Edit Menu

Menu Item Description Shortcut Key
Undo Undoes the last action in a document tab. Undo and redo actions are unlimited. Ctrl + Z
Redo Redoes the last action that was undone in a document tab. Ctrl + Y
Cut Copies the selected element to the clipboard and delete it. Ctrl + X
Copy Copies the selected element to the clipboard. Ctrl + C
Paste Pastes the contents of the clipboard in the current editor. Ctrl + V
Delete Deletes the selected element. Delete
Find Searches the model for text. The following texts are searched: all texts that appear in the end user interface (captions of labels, buttons, etc); names and documentation of documents; entity, association, and attribute names and documentation; access rule documentation; form widget names; captions and documentation of microflow objects; variable definitions in microflow. Ctrl + F
Find Advanced Opens a dialog box that allows for advanced search operations. Examples are searching for any document type and searching for unused documents. Ctrl + Shift + F
Find Usages Opens the Find Results pane and displays usages of the selected object. Ctrl + Alt + F
Next Find Result Highlights the next find result in the Find Results pane and open it in an editor. F3
Previous Find Result Highlights the previous find result in the Find Results pane and open it in an editor. Shift + F3
Go to Quickly navigates to any document or domain model element in the project by typing a few letters and pressing Enter. Ctrl + G
Next Error Highlights the next error in the Error List pane and open it in an editor. F8
Previous Error Highlights the previous error result in the Error List pane and open it in an editor. Shift + F8
Preferences Opens the Preferences dialog box, where you can set your general, model, and advanced editing preferences.

4.3 View Menu

Menu Item Description Shortcut Key
Changes Opens the dockable window pane Changes.
Connector Opens the dockable window pane Connector.
Console Opens the dockable window pane Console.
Documentation Opens the dockable window pane Documentation.
Error List Opens the dockable window pane Error List.
Find Results 1 Opens the dockable window pane Find Results 1.
Find Results 2 Opens the dockable window pane Find Results 2.
Project Explorer Opens the dockable window pane Project Explorer.
Properties Opens the dockable window pane Properties.
Stories Opens the dockable window pane Stories.
Toolbox Opens the dockable window pane Toolbox.
Debug Windows > Breakpoints Opens the dockable window pane Breakpoints.
Debug Windows > Debugger Opens the dockable window pane Debugger.
Debug Windows > Variables Opens the dockable window pane Variables.
Full Screen Temporarily hides all dockable window panes so that the tabbed documents can be shown in full screen. F11
Reset Layout Resets the layout of the Modeler to factory defaults.

4.4 Project Menu

Menu Item Description Shortcut Key
Update Updates the local app to the latest revision that was committed to the version control server.
Commit Commits all local changes made to the app since the previous commit to the version control server.
Show Changes on Disk Opens a dialog that shows which files on disk have been changed since the last commit.
More Versioning > History Shows the history of committed revisions of the app.
More Versioning > Download from Version Control Server Downloads an app from the Team Server or another SVN server. This creates a local working copy of the app for development.
More Versioning > Upload to Version Control Server Uploads a local app to a new or existing Team Server repository, or to another SVN server. This is only possible if the app is not yet version controlled.
More Versioning > Manage Branch Lines Manages branch lines on the version control server that can be used to develop functionality separately from the main line.
More Versioning > Merge Changes Here Merges changes that were committed in another development line to the development line that is currently opened in the Modeler.
More Versioning > Reverse Merge Changes Allows locally rolling back changes that were committed to the version control repository. These local changes can then be committed as a new revision.
More Versioning > Sync with Web Modeler Syncs your app project with the Web Modeler. For more information, see How to Sync the Web Modeler with the Desktop Modeler.
More Versioning > Finish Sync with Web Modeler Finishes the sync with the Web Modeler.
More Versioning > Cancel Sync with Web Modeler Cancels the sync with the Web Modeler.
More Versioning > Add Snapshot of Data Creates a snapshot of the built-in database and adds that to the version control repository. This is especially useful for adding test data to your app or for demo purposes.
Tools > Batch update button icons Opens the Batch Update Button Icons dialog box so that you can configure the batch update of many button icons at once.
Tools > Batch update layouts Opens the Batch Update Layouts dialog box so that you can configure the batch update of the layouts of many pages at once.
Tools > Batch convert Split panes Opens the Batch Convert Split Panes dialog box so that you can configure the batch update.
Tools > Check Widgets Checks that the widgets you have implemented in the app project have been built correctly.
Synchronize Project Directory If necessary, this action creates folders inside the project directory (resources, widgets, theme, etc.). It also reads the widget packages that are currently inside the widgets folders. For example, if you add widgets to the widgets folder, you needs to synchronize the project directory for them to appear in the form toolbox. F4
Show Project Directory in Explorer Shows the directory that contains the project file (.mpr) and other assets such as resources and Java actions in Windows Explorer.
Deploy for Eclipse Deploys the project to the deployment directory. The Java stubs are generated so that you can start editing them in Eclipse. This action does not compile the Java actions. Use this if you are writing Java actions and you want to compile and debug them through Eclipse. F6
Create Deployment Package Creates a Mendix Deployment Archive package (.mda) that contains all necessary files to run the project. This can be used if you want to deploy your project on a Windows server or on a custom Mendix Cloud. F7
Clean Deployment Directory Cleans the deployment directory.
Deploy to Licensed Cloud Node Deploys the latest committed revision of a Team Server project to the associated Mendix Cloud node. Ctrl + F5

4.5 Run Menu

Menu Item Description Shortcut Key
Run Deploys and run the project locally. The Console pane is activated and this shows the output of the server that runs the project. F5
Run on Cloud Foundry Opens the Edit Cloud Foundry Settings dialog box so you can run your app on Cloud Foundry.
Edit Cloud Foundry Settings Opens the Edit Cloud Foundry Settings dialog box so you can edit your Cloud Foundry settings.
Run Locally Runs the project locally so you can view the app. F5
Stop Stops the currently running project. Shift + F5
Configuration Sets the configuration level (Default).
Default log level Allows setting the default log level before running the project locally. The options are Trace, Debug, Info (default), Warning, Error, Critical.
Debug Allows you to connect the Debugger.
Responsive Browser Shows the web client for the currently running project in the browser. F9
Tablet Browser Shows the tablet mobile client for the currently running project in the browser. Ctrl + Shift + F9
Phone Browser Shows the mobile client for the currently running project in the browser. Ctrl + F9
Hybrid Phone App Online Views the app as a phone app online.
View in the Mendix App Views the app via the Mendix mobile app.

4.6 Language Menu

Menu Item Description Shortcut Key
Current Language Displays the current language of your app project.
Language Settings Opens the Project Settings dialog box to the Languages tab so that you can adjust the language configuration of the app project.
Batch Replace Opens a form in which you can correct texts within one language. This is useful to check whether texts presented to the user are consistent.
Batch Translate Opens a form in which you can quickly translate many texts from one language to another.
Language Operations Opens a form in which you can copy, move, swap, or delete all translations in a given language for selected modules.

4.7 Help Menu

Menu Item Description Shortcut Key
Help Opens the documentation page about the currently selected element. If an entity is selected, for example, the documentation for entities will be shown. F1
Help Contents Opens the start page of the documentaton in the default web browser.
Ask a Question Opens the Mendix Forum in the default web browser.
Open Log File Directory Opens the log files for your app project locally.
About Mendix Modeler Shows information about the current version of the Mendix Modeler.

5 General Shortcut Keys

In the main window pane, Ctrl + Tab can be used to navigate between all open documents. Other shortcut keys that can be used in the main window pane can be found next to their relevant menu item in the Menus section above.

In most dialog boxes for editing properties, the following shortcut keys can be used:

Key Description
Ctrl + Enter Confirms all changes and closes the form. Works as if the OK button was clicked. This is especially useful if the focus is on a multi-line text box; otherwise, pressing Enter will have the same effect.
Escape Cancels all changes and closes the form. Works as if the Cancel button was clicked.
Ctrl + Mouse scroll wheel Zooms in or out. This works in all editors.
Shift + Mouse scroll wheel Scrolls left or right. Works as if you were using the horizontal scroll bars.

In most edit grids (such as the list of attributes in the entity properties), the following shortcut keys can be used:

Key Description
Ctrl + N Creates a new item.
Enter Edits the currently selected item.
Delete Deletes the currently selected item(s).

6 Domain Model Editor Shortcut Keys

The following shortcut keys are available in the domain model editor:

Key Description
F2 Edits the name of the selected element.
Ctrl + A Selects all entities.
Esc Clears selection.

7 Form Editor Shortcut Keys

The following shortcut keys are available in the form editor:

Key Description
Arrow keys Moves the selection box to the widget or element in the direction of the arrow key. For example, if currently a label is selected and you press the right arrow key, the text box to the right of it becomes selected.
Ctrl + arrow keys Moves the currently selected item up/down or left/right. This works on table columns and rows, tab pages, grid and data view buttons, search fields, etc.
Enter Edits the properties of the currently selected object in a dialog box.
F2 Edits the caption of a label or button inline in the form. You can also just start typing a letter or a digit and the caption will be replaced by what you type.

8 Microflow Editor Shortcut Keys

The following shortcut keys are available in the microflow editor:

Key Description
Arrow keys Moves the selection box to the activity or element in the direction of the arrow key. For example, if currently a show page activity is selected and you press the right arrow key, the end event to the right of it becomes selected.
Ctrl + arrow keys Moves the currently selected item up/down or left/right.
Enter Edits the properties of the currently selected object in a dialog box.
F2 Edits the name of the variable generated by the currently selected activity. This shortcut will not function on activities that do not result in a variable.
Home Highlights and focus on the start event of the current microflow.
End Highlights and focus on an end event in the current microflow. If there are multiple end events, clicking End multiple times will toggle between the different events.
Shift when resizing an activity When resizing the entity, by holding Shift , the microflow component will stay centered at its current position and will expand equally in all directions.
Ctrl when selecting multiple activities When pressing the Ctrl, you can select additional microflow components. Clicking a selected component while holding Ctrl will deselect it.