Menus

Last update: Edit

1 Introduction

The top-bar of Studio Pro contains the following menus:

  • File – allows you to manage documents and projects
  • Edit – allows you to perform editing functions such as search or copy within Studio Pro
  • View – allows you to choose how Studio Pro and dockable panes within Studio Pro are displayed
  • Project – contains project-wide settings
  • Run – contains actions for deploying and monitoring your app
  • Version Control – contains setting for version control
  • Language – contains language and translation settings
  • Help – allows you to view documentation, Mendix Forum, open log file directory, or view information on the current information of Studio Pro

2 File Menu

Via the File menu you can manage documents and projects. For more information on the File menu, see File Menu.

3 Edit Menu

The Edit menu allows you to perform editing functions, such as cut/copy/paste. You can also set preferences via this menu. For more information on the Edit menu, see Edit Menu.

4 View Menu

The View menu allows you to view dockable panes, to enable the full screen mode, and reset the project layout. For more information on the View menu and its items, see View Menu.

5 Project Menu

In the Project menu, you can view and/or manipulate settings that are connected to your project and deployment. For more information on the Project menu, see Project Menu.

6 Run Menu

The Run menu contains actions for deploying and monitoring your app, such as Run, Run locally, or Debugger. For more information on the Run menu, see Run Menu.

7 Version Control Menu

In the Version Control menu, you can view and/or manipulate settings on the version control. More information on the Version Control menu, see Version Control Menu.

8 Language Menu

Menu Item Description Shortcut Key
Current Language Displays the current language of your app project.
Language Settings Opens the Project Settings dialog box to the Languages tab so that you can adjust the language configuration of the app project.
Batch Replace Opens a dialog window in which you can correct texts within one language. This is useful to check whether texts presented to the user are consistent.
Batch Translate Opens a dialog window in which you can quickly translate many texts from one language to another.
Language Operations Opens a dialog window in which you can copy, move, swap, or delete all translations in a given language for selected modules.

9 Help Menu

Menu Item Description Shortcut Key
Help Opens the documentation page about the currently selected element. If an entity is selected, for example, the documentation for entities will be shown. F1
Help Contents Opens the start page of the documentation in the default web browser.
Ask a Question Opens the Mendix Forum in the default web browser.
Open Log File Directory Opens the log files for your app project locally.
About Mendix Studio Pro Shows information about the current version of Mendix Studio Pro.

10 Read More