Studio Pro Overview

Last update: Edit

1 Introduction

Mendix Studio Pro is the tool for creating, viewing, and editing your Mendix applications. A Mendix app is called a project in Studio Pro. A project consists of many documents that are grouped in modules and folders. There are some project-level settings, but the core of the functionality is inside the modules. Examples of documents are project settings, domain models, pages, and microflows. One Studio Pro instance can have only one project open at a time, but you can open two Studio Pro instances when necessary.

This documentation describes the graphical user interface of Studio Pro. The rest of the documentation follows the structure of the project explorer.

2 Document Tabs

The documents you view and edit are shown in tabs. You can have a number of tabs open, just like in a modern web browser. They can be closed, reordered, and shown side by side. Each document has its own save state, history, and future, so undo and redo actions are unlimited.

Menu Item Description Shortcut Key
New Document Creates a new document within the project that is currently open. You can choose the name, location and type of the document. Ctrl + N
New Project Creates a new single-developer project. A single-developer project is simply a file (with the extension .mpr , which stands for “Mendix project”) that is stored in the local file system. Ctrl + Shift + N
Open Project Opens an existing single-developer project (.mpr) or a project package (.mpk). See New Project above for information on single-developer projects. Ctrl + Shift + O
Recent Projects Shows a list of recently opened projects for quick opening.
Save Saves the changes in the currently active document tab. Ctrl + S
Save All Saves the changes in all documents that are open. Ctrl + Shift + S
Close Closes the current document. You will be asked to save or discard changes when needed. Ctrl + W
Close All Closes all document tabs. You will be asked to save or discard changes when needed. Ctrl + Shift + W
Close Project Closes the currently open project and return to the start page.
Export as Image Exports the current document as an image in the .png format. The following document types can be exported as images: pages, microflows, domain models, document templates, and XML mappings.
Export Project Package Exports the current app to a project package (.mpk) file. This is useful for example when you want to give someone the entire app, or when you need to provide a test app when submitting a ticket.
Import Project Package Imports a project package that was created with the Export Project Package menu item.
Exit Closes Studio Pro

4 Edit Menu

Menu Item Description Shortcut Key
Undo Undoes the last action in a document tab. Undo and redo actions are unlimited. Ctrl + Z
Redo Redoes the last action that was undone in a document tab. Ctrl + Y
Cut Copies the selected element to the clipboard and delete it. Ctrl + X
Copy Copies the selected element to the clipboard. Ctrl + C
Paste Pastes the contents of the clipboard in the current editor. Ctrl + V
Delete Deletes the selected element. Delete
Find Searches the model for text. The following texts are searched: all texts that appear in the end-user interface (for example captions of labels or buttons); names and documentation of documents; entity, association, and attribute names and documentation; access rule documentation; page widget names; captions and documentation of microflow objects; and names of items in microflows. Ctrl + F
Find Advanced Opens a dialog box that allows for advanced search operations. Examples are searching for any document type and searching for unused documents. Ctrl + Shift + F
Find Usages Opens the Find Results pane and displays usages of the selected object. Ctrl + Alt + F
Next Find Result Highlights the next find result in the Find Results pane and open it in an editor. F3
Previous Find Result Highlights the previous find result in the Find Results pane and open it in an editor. Shift + F3
Go to Quickly navigates to any document or domain model element in the project by typing a few letters and pressing Enter. Ctrl + G
Next Error Highlights the next error in the Error List pane and open it in an editor. F8
Previous Error Highlights the previous error result in the Error List pane and open it in an editor. Shift + F8
Preferences Opens the Preferences dialog box, where you can set your general, model, and advanced editing preferences.

5 View Menu

The View menu allows you to view dockable panes, to enable the full screen mode, and reset the project layout. For more information on the View menu and its items, see View Menu.

6 Project Menu

In the Project menu, you can view and/or manipulate settings that are connected to the version control or deployment. For more information on the Project menu, see Project Menu.

7 Run Menu

Menu Item Description Shortcut Key
Run Deploys and run the project locally. The Console pane is activated and this shows the output of the server that runs the project. F5
Run on Cloud Foundry Opens the Edit Cloud Foundry Settings dialog box so you can run your app on Cloud Foundry.
Edit Cloud Foundry Settings Opens the Edit Cloud Foundry Settings dialog box so you can edit your Cloud Foundry settings.
Run Locally Runs the project locally so you can view the app. F5
Stop Stops the currently running project. Shift + F5
onfiguration Sets the configuration level (Default).
efault log level Allows setting the default log level before running the project locally. The options are Trace, Debug, Info (default), Warning, Error, Critical.
Debug Allows you to connect the Debugger.
Responsive Browser Shows the web client for the currently running project in the browser. F9
Tablet Browser Shows the tablet mobile client for the currently running project in the browser. Ctrl + Shift + F9
Phone Browser Shows the mobile client for the currently running project in the browser. Ctrl + F9
Hybrid Phone App Online Views the app as a phone app online.
View in the Mendix App Views the app via the Mendix Mobile app.

8 Language Menu

Menu Item Description Shortcut Key
Current Language Displays the current language of your app project.
Language Settings Opens the Project Settings dialog box to the Languages tab so that you can adjust the language configuration of the app project.
Batch Replace Opens a dialog window in which you can correct texts within one language. This is useful to check whether texts presented to the user are consistent.
Batch Translate Opens a dialog window in which you can quickly translate many texts from one language to another.
Language Operations Opens a dialog window in which you can copy, move, swap, or delete all translations in a given language for selected modules.

9 Help Menu

Menu Item Description Shortcut Key
Help Opens the documentation page about the currently selected element. If an entity is selected, for example, the documentation for entities will be shown. F1
Help Contents Opens the start page of the documentation in the default web browser.
Ask a Question Opens the Mendix Forum in the default web browser.
Open Log File Directory Opens the log files for your app project locally.
About Mendix Studio Pro Shows information about the current version of Mendix Studio Pro.

10 Shortcut Keys

10.1 General Shortcut Keys

In the main window pane, Ctrl + Tab can be used to navigate between all open documents. Other shortcut keys that can be used in the main window pane can be found next to their relevant menu item in the Menus section above.

In most dialog boxes for editing properties, the following shortcut keys can be used:

Key Description
Ctrl + Enter Confirms all changes and closes the dialog window. Works as if the OK button was clicked. This is especially useful if the focus is on a multi-line text box; otherwise, pressing Enter will have the same effect.
Esc Cancels all changes and closes the dialog window. Works as if the Cancel button was clicked.
Ctrl + Mouse scroll wheel Zooms in or out. This works in all editors.
Shift + Mouse scroll wheel Scrolls left or right. Works as if you were using the horizontal scroll bars.

In most edit grids (such as the list of attributes in the entity properties), the following shortcut keys can be used:

Key Description
Ctrl + N Creates a new item.
Enter Edits the currently selected item.
Delete Deletes the currently selected item(s).

10.2 Domain Model Editor Shortcut Keys

The following shortcut keys are available in the domain model editor:

Key Description
F2 Edits the name of the selected element.
Ctrl + A Selects all entities.
Esc Clears selection.

10.3 Page Editor Shortcut Keys

The following shortcut keys are available in the page editor:

Key Description
Arrow keys Moves the selection box to the widget or element in the direction of the arrow key. For example, if currently a label is selected and you press the right arrow key, the text box to the right of it becomes selected.
Ctrl + arrow keys Moves the currently selected item up/down or left/right. This works on table columns and rows, tab pages, grid and data view buttons, search fields, etc.
Enter Edits the properties of the currently selected object in a dialog box.
F2 Edits the caption of a label or button inline on the page. You can also just start typing a letter or a digit and the caption will be replaced by what you type.

10.4 Microflow Editor Shortcut Keys

The following shortcut keys are available in the microflow editor:

Key Description
Arrow keys Moves the selection box to the activity or element in the direction of the arrow key. For example, if currently a show page activity is selected and you press the right arrow key, the end event to the right of it becomes selected.
Ctrl + arrow keys Moves the currently selected item up/down or left/right.
Enter Edits the properties of the currently selected object in a dialog box.
F2 Edits the name of the return value of the currently selected activity. This shortcut will not function on activities that do not return a result.
Home Highlights and focus on the start event of the current microflow.
End Highlights and focus on an end event in the current microflow. If there are multiple end events, clicking End multiple times will toggle between the different events.
Shift when resizing an activity When resizing the entity, by holding Shift , the microflow component will stay centered at its current position and will expand equally in all directions.
Ctrl when selecting multiple activities When pressing the Ctrl, you can select additional microflow components. Clicking a selected component while holding Ctrl will deselect it.

10.5 Microflow Debugger Shortcut Keys

The following shortcut keys are available for the the microflow debugger:

Key Description
Alt + F5 Step into – moves the debugger into the sub-microflow or loop.
Alt + F6 Step over – moves the debugger to the next step in the same microflow.
Alt + F7 Step out – instructs the debugger to leave the sub-microflow or loop.
Alt + F8 Continue – instructs the debugger to continue until it reaches another breakpoint.